Portal Gier Strategicznych | The Generals' Guild | Biblioteka Gier Portal Gier Strategicznych | The Generals' Guild | Biblioteka Gier
Portal Gier Strategicznych | The Generals' Guild | Biblioteka Gier Portal Gier Strategicznych | The Generals' Guild | Biblioteka Gier
Portal Gier Strategicznych | The Generals' Guild | Biblioteka Gier Portal Gier Strategicznych | The Generals' Guild | Biblioteka Gier
Portal Gier Strategicznych | The Generals' Guild | Biblioteka Gier Strona główna | Pomoc | Szukaj | Zaloguj się | Rejestracja
Grudzień 06, 2019, 02:04:16 *
Witamy, Gość. Zaloguj się lub zarejestruj.
Czy dotarł do Ciebie email aktywacyjny?

Zaloguj się podając nazwę użytkownika, hasło i długość sesji
 
 
Strony: 1 [2]   Do dołu
  Drukuj  
Autor Wątek: Kampania W94 "Kampania Vietkongu i Wietnamu Północnego"  (Przeczytany 3185 razy)
Waldzios
Administrator
Marszałek (General of Army)
*
Offline Offline

Wiadomości: 3334


"Let me see your war face."


« Odpowiedz #15 : Czerwiec 15, 2019, 10:40:47 »

To nie wada tylko cecha nowej wersji.
W nowym silniku jednostki z listy zakupów gracza muszą się pokrywać z krajami zdefiniowanymi jako wspierające w scenariuszu. Inaczej nie będą dostępne do zakupu.
To kompletnie bez sensu.
Rozwala cały sens list zakupów, w kontekście dodawania obcego sprzętu...
Szczególnie, że 'All countries' nie da się ustawić jako kraj wspierający (jeszcze niedawno Luis dodawał do CFG 'allow_country0_gtp', w celu obsługi transportów  'All countries').

Jak dla mnie to nie tylko wada, ale krytyczny problem. Listy zakupów (w kampaniach takich jak W94) praktycznie stracą sens.
Przecież nie dodasz LWP jako sojusznika do kampanii rozgrywanej Vietcongiem.
« Ostatnia zmiana: Czerwiec 15, 2019, 10:47:27 wysłane przez Waldzios » Zapisane

GusOpen - aktualizacje/updates: EFile , EquipIcons
Jaro
Moderator
Marszałek (General of Army)
*
Offline Offline

Wiadomości: 1207


« Odpowiedz #16 : Czerwiec 16, 2019, 07:42:37 »

Zgadzam się z Tobą. All countries będą dostępne na 100%. Właśnie przeczytałem maila od Luisa i raczej poprawi tak, aby listy zakupów były dostępne niezależnie od krajów wspierających. Jestem dobrej myśli.
Zapisane

Pozdrawiam,
Jaro
------------------------------------------------------
Repozytorium plików instalacyjnych gry:
Dropbox: https://www.dropbox.com/sh/z4l7rs71sxk1jc6/AAD8v6sMojApzyD4NG3IFK4ca?dl=0
OneDrive: https://1drv.ms/f/s!Am2aTZH9AOcoanwyUg8_mMB5lwI
Jaro
Moderator
Marszałek (General of Army)
*
Offline Offline

Wiadomości: 1207


« Odpowiedz #17 : Czerwiec 22, 2019, 12:30:24 »

Wkrótce będzie można zagrać w nową wersję kampanii. Wymagany jest nowy silnik OpenGen 0.93.0
Kampanie wysłana do Kowdara - oczekujcie na publikację.
W nowej instalce również się pojawi.

Testowana na 100%. Gra jest przyjemna i stanowi jakieś wyzwanie.

Kampania używa AI 3.0, która jest w wersji rozwojowej. Różnice łatwo zobaczyć porównując rozgrywkę wersji 4.0 i obecnej pierwszego scenariusza ? większość jednostek wroga atakuje VH zamiast błąkać się po lasach.
Największe zmiany przeszedł właśnie pierwszy scenariusz aby w nowych warunkach możliwe było zwycięstwo. Wydłużona ilość tur pozwala zdobyć trochę kasy a siła bazowa jednostek teraz jest 10, co spowoduje ich użyteczność w późniejszych bitwach.

Większość transportów śmigłowcowych zmieniona na HTP bo umożliwia wyładowanie jednostki również na sąsiednie pola.
Pojedyncze jednostki używają śmigłowców jako transport organiczny bo tylko on umożliwia ponowne załadowanie do śmigłowca.

W początkowych scenariuszach nie mamy dostępu do transportu motorowego i ciężkiego sprzętu.

Miłej zabawy - ja się bawiłem świetnie.

Zapisane

Pozdrawiam,
Jaro
------------------------------------------------------
Repozytorium plików instalacyjnych gry:
Dropbox: https://www.dropbox.com/sh/z4l7rs71sxk1jc6/AAD8v6sMojApzyD4NG3IFK4ca?dl=0
OneDrive: https://1drv.ms/f/s!Am2aTZH9AOcoanwyUg8_mMB5lwI
Waldzios
Administrator
Marszałek (General of Army)
*
Offline Offline

Wiadomości: 3334


"Let me see your war face."


« Odpowiedz #18 : Czerwiec 22, 2019, 01:26:22 »

Kampania używa AI 3.0, która jest w wersji rozwojowej.
Sprawdzałeś co się stanie jeśli ktoś używa OpenGenDD? Takich osób nadal jest sporo...
Zapisane

GusOpen - aktualizacje/updates: EFile , EquipIcons
Jaro
Moderator
Marszałek (General of Army)
*
Offline Offline

Wiadomości: 1207


« Odpowiedz #19 : Czerwiec 22, 2019, 01:35:15 »

Kampania używa AI 3.0, która jest w wersji rozwojowej.
Sprawdzałeś co się stanie jeśli ktoś używa OpenGenDD? Takich osób nadal jest sporo...
W ogóle się nie uruchomi. Może warto zachować wersję 4.0 jako zgodną z OpenGenDD Huh?
Warto by, w osobnym wątku, pogadać o tym jak obsłużyć takie sytuacje. Silnik się rozwija, developerzy zyskują możliwości lepszego sterownia, korzystania z nowych funkcjonalności jednostek... Nie unikniemy takich zmian ale na pewno warto by zachować stare wersje dla nierozwijanego już silnika.
Zapisane

Pozdrawiam,
Jaro
------------------------------------------------------
Repozytorium plików instalacyjnych gry:
Dropbox: https://www.dropbox.com/sh/z4l7rs71sxk1jc6/AAD8v6sMojApzyD4NG3IFK4ca?dl=0
OneDrive: https://1drv.ms/f/s!Am2aTZH9AOcoanwyUg8_mMB5lwI
Waldzios
Administrator
Marszałek (General of Army)
*
Offline Offline

Wiadomości: 3334


"Let me see your war face."


« Odpowiedz #20 : Czerwiec 22, 2019, 02:08:10 »

Raczej skłaniałbym się ku wstecznej kompatybilności (czyli AI 2.0 w oficjalnej wersji).
OpenGenDD pozwala niektórym komputerom (według moich źródeł to nawet 5% komputerów kompatybilnych z WIN7 i WIN10) ominąć problem z wielkością tekstur (sprzętowe ograniczenie maksymalnej wielkości tekstury) i SDL2.
Jeśli połączmy wielkie mapy i AI 3.0, to dla jakiejś grupy ludzi OG przestanie być grywalne.

EDIT.
Na tą chwile nie ma oficjalnej wersji OpenGen 0.93.x, ani oficjalnej wersji AI 3.0.
Kiedy/jeśli oba się pojawią, wtedy będzie można poprosić Luisa o przygotowanie wersji OpenGenDD, która będzie automatycznie downgrade'ować wersje AI (to nie powinien być problem).
Do tego momentu sugerowałbym jednak zachować pełną kompatybilność z oficjalna wersją OpenGen 0.92.0.x (stable) i  AI 2.0.
« Ostatnia zmiana: Czerwiec 22, 2019, 02:47:47 wysłane przez Waldzios » Zapisane

GusOpen - aktualizacje/updates: EFile , EquipIcons
sympatyk
Marszałek (General of Army)
*
Offline Offline

Wiadomości: 1387


« Odpowiedz #21 : Czerwiec 22, 2019, 02:47:29 »

Ja już kompletnie się pogubiłem ..
.. która wersja suite z którym exe powinna być używana
No i te nieszczęsne SDL2 - wielkość tekstury do obsłużenia od czego zależy?
Od karty graficznej i jej możliwości?, od pamięci (ram)?

Halo Waldzioś - przydał by się temat porządkujący /rozjaśniający te wszystkie techniczne rzeczy
A jeszcze wersje Al
To wszystko na tle systemów operacyjnych win 98, 7, 10 ...
Może jakaś tabelka?, porównanie ...
Co, Ty na to?
Zapisane
Jaro
Moderator
Marszałek (General of Army)
*
Offline Offline

Wiadomości: 1207


« Odpowiedz #22 : Czerwiec 22, 2019, 03:17:24 »

Raczej skłaniałbym się ku wstecznej kompatybilności (czyli AI 2.0 w oficjalnej wersji).
OpenGenDD pozwala niektórym komputerom (według moich źródeł to nawet 5% komputerów kompatybilnych z WIN7 i WIN10) ominąć problem z wielkością tekstur (sprzętowe ograniczenie maksymalnej wielkości tekstury) i SDL2.
Jeśli połączmy wielkie mapy i AI 3.0, to dla jakiejś grupy ludzi OG przestanie być grywalne.


AI 2.0 ma tą brzydką cechę, że artyleria i jednostki obrony przeciwlotniczej są bardzo niechętne do podążania za atakiem. Ponadto piechota i czołgi rozstawione w dwóch grupach zamiast atakować "swoje" - najbliższe VH potrafią uprzeć się na jeden VH. Oczywiście można to wysterować ale wtedy gra staje się bardzo przewidywalna i powtarzalna.  Nie wiem też, czy AI 2.0 będzie dalej rozwijane a to oznacza brak wsparcia dla poprawnego transportu śmigłowcowego.

Moim zdaniem i tak nie unikniemy rozwiązania problemu z teksturami i trzeba by się tym zająć wraz z Luisem.
Sprawdzę, czy któryś z moich komputerów ma ten problem.

Cytuj
EDIT.
Na tą chwile nie ma oficjalnej wersji OpenGen 0.93.x, ani oficjalnej wersji AI 3.0.
Kiedy/jeśli oba się pojawią, wtedy będzie można poprosić Luisa o przygotowanie wersji OpenGenDD, która będzie automatycznie downgrade'ować wersje AI (to nie powinien być problem).
Do tego momentu sugerowałbym jednak zachować pełną kompatybilność z oficjalna wersją OpenGen 0.92.0.x (stable) i  AI 2.0.
Oficjalna wersja OpenGen 0.93.x spodziewana jest w ciągu najbliższych dwóch tygodni.
IMHO downgreadowanie AI ma mały sens bo AI będzie się zachowywać beznadziejnie. Kampania będzie grywalna jako i teraz jest grywalna.
Zapisane

Pozdrawiam,
Jaro
------------------------------------------------------
Repozytorium plików instalacyjnych gry:
Dropbox: https://www.dropbox.com/sh/z4l7rs71sxk1jc6/AAD8v6sMojApzyD4NG3IFK4ca?dl=0
OneDrive: https://1drv.ms/f/s!Am2aTZH9AOcoanwyUg8_mMB5lwI
Jaro
Moderator
Marszałek (General of Army)
*
Offline Offline

Wiadomości: 1207


« Odpowiedz #23 : Czerwiec 22, 2019, 03:29:27 »

Sprawdzę, czy któryś z moich komputerów ma ten problem.
Niestety u mnie maksymalny rozmiar tekstury to ok 8000.
Wiecie, kto ma problem z maksymalnym rozmiarem tekstury?
W najnowszej wersji testowej OG można to sprawdzić za pomocą ALT+F7
Zapisane

Pozdrawiam,
Jaro
------------------------------------------------------
Repozytorium plików instalacyjnych gry:
Dropbox: https://www.dropbox.com/sh/z4l7rs71sxk1jc6/AAD8v6sMojApzyD4NG3IFK4ca?dl=0
OneDrive: https://1drv.ms/f/s!Am2aTZH9AOcoanwyUg8_mMB5lwI
Waldzios
Administrator
Marszałek (General of Army)
*
Offline Offline

Wiadomości: 3334


"Let me see your war face."


« Odpowiedz #24 : Czerwiec 22, 2019, 03:52:29 »

Ja już kompletnie się pogubiłem ..
.. która wersja suite z którym exe powinna być używana
Wedle mojej logiki. Jeśli coś testujesz, to możesz używać jakiejkolwiek wersji.
Ale jeśli przygotowujesz coś co będzie oficjalnie opublikowane, to IMHO powinieneś używać oficjalnej (w danym momencie) wersji.

Na przykład, ja używam kilka rożnych wersji Suite (do różnych celów), ale pliki efila edytuje wyłącznie w Suite 5.0.69.0 (25 Nov 2018). Ponieważ tą wersje uważam za najbardziej kompatybilną z oficjalnym silnikiem.

No i te nieszczęsne SDL2 - wielkość tekstury do obsłużenia od czego zależy?
Od karty graficznej i jej możliwości?, od pamięci (ram)?
Zbyt mało wiem o SDL2 i o sposobie w jaki Luis rozwiązał te kwestie w kodzie, by wypowiedzieć się precyzyjnie.

Rozmiar obsługiwanej tekstury teoretycznie zależy od pamięci ram karty graficznej (192MB dla tekstury 8192*8192 24bit).
Problem w tym, że niektóre zintegrowane karty mimo wystarczającej ilości pamięci (współdzielą pamięć ram komputera) mają sprzętowe ograniczenie maksymalnego rozmiaru tekstury (4096*4096).

Z tego co czytałem o SDL2 (analizowałem temat dość pobieżnie) to przy sprzętowym renderingu, niezależnie od podejścia (nawet przy dzieleniu tekstury na kawałki), biblioteka próbuje całą teksturę wrzucić do pamięci karty graficznej. Dlatego wątpię by Luis był w stanie łatwo to naprawić.

AI 2.0 ma tą brzydką cechę...
Nie bronię AI 2.0, tylko wstecznej kompatybilności.
Nie chce odbierać ludziom możliwości gry (nawet przy gorszym AI).

IMHO downgreadowanie AI ma mały sens bo AI będzie się zachowywać beznadziejnie. Kampania będzie grywalna jako i teraz jest grywalna.
Pisałem o downgrade'owaniu tylko w przypadku OpenGenDD.
Silnik OpenGenDD wczytałby scenariusz, stwierdził że ustawione jest AI 3.0, i automatycznie zamienił jest na AI 2.0, tak by możliwa była rozgrywka.

Skoro OpenGenDD czyta nową strukturę plików, w tym nowe dodatki (mimo że ich nie używa), to nie widzę przeciwwskazań by czytał informacje o nowym AI (ale ją ignorował, i zastępował wcześniejszą wersją).

W najnowszej wersji testowej OG można to sprawdzić za pomocą ALT+F7
Niezbyt wiele informacji:


« Ostatnia zmiana: Czerwiec 22, 2019, 03:59:42 wysłane przez Waldzios » Zapisane

GusOpen - aktualizacje/updates: EFile , EquipIcons
Waldzios
Administrator
Marszałek (General of Army)
*
Offline Offline

Wiadomości: 3334


"Let me see your war face."


« Odpowiedz #25 : Czerwiec 26, 2019, 11:20:00 »

Kampania używa AI 3.0, która jest w wersji rozwojowej.
Sprawdzałeś co się stanie jeśli ktoś używa OpenGenDD? Takich osób nadal jest sporo...
W ogóle się nie uruchomi.
Przed chwila sprawdziłem OpenGenDD (version 0.90.61.5 stable) i wbrew temu co napisałeś, kampanie z AI 3.0 się uruchamiają.
Tak jak sugerowałem wcześniej, silnik korzysta w zamian z AI 2.0.

Oficjalna wersja OpenGen 0.93.x spodziewana jest w ciągu najbliższych dwóch tygodni.
Oficjalna wersja się pojawiła, ale AI 3.0 nadal ma status rozwojowy (Dev).

Zapisane

GusOpen - aktualizacje/updates: EFile , EquipIcons
Jaro
Moderator
Marszałek (General of Army)
*
Offline Offline

Wiadomości: 1207


« Odpowiedz #26 : Czerwiec 26, 2019, 11:39:59 »

To dobrze że działa. Ja testowałem na OG_DD 0.90.61.2 wersji od Kowdara.

Nie słyszałem o planach ukończenia AI 3.0
Zapisane

Pozdrawiam,
Jaro
------------------------------------------------------
Repozytorium plików instalacyjnych gry:
Dropbox: https://www.dropbox.com/sh/z4l7rs71sxk1jc6/AAD8v6sMojApzyD4NG3IFK4ca?dl=0
OneDrive: https://1drv.ms/f/s!Am2aTZH9AOcoanwyUg8_mMB5lwI
Strony: 1 [2]   Do góry
  Drukuj  
 
Skocz do:  

Aktualnie w bazie: 59 gry strategiczne 12 stare gry do pobrania 5 recenzje 2 poradniki 37 plików 333 zdjęć w galerii 87 newsów
Polityka prywatności | Disclaimer | O nas | Współpraca | Sitemap | Kontakt | Kanały RSS
© 1996-2008 The Generals' Guild Team All Rights Reserved. Wszelkie prawa zastrzeżone.
Projekt F.D.G. STUDIO, script by Szarik and Depet
Powered by SMF 1.1.4 | SMF © 2006-2007, Simple Machines LLC
War in the Pacific / Decisive Battles by Ryan | Games House | Panzer General | Heroes of Might and Magic
The Generals' Guild czyli Gildia Generałów to serwis graczy - pasjonatów gier strategicznych o bogatej tradycji istniejący od 1996 roku.
Naszym celem jest stworzenie rzetelnego i interesującego portalu poświęconego takim pozycjom na rynku gier jak złożone, wojenne gry
strategiczne, taktyczne i operacyjne
we wszystkich znanych kategoriach - począwszy od tematyki średniowiecza po science-fiction i fantasy...